Úvod

Tato příručka poskytuje základní informace pro používání vizualizačního nástroje ClueMaker. Začíná popisem instalace nástroje a jeho prvního spuštění, následují kapitoly popisující import dat a práci s nimi.

Základní pojmy

  • Atribut: Datové pole, například datum, příjmení, číslo účtu.
  • Entita: Obecně množina informací o určitém subjektu: osoba, účet, firma, smlouva …. V grafu může jít jak o uzel, tak i o vazbu.
  • Uzel: Základní článek v grafu, představuje datovou entitu (osobu, firmu, účet….) pro kterou hledáme vazby na sousedy.
  • Vazba: Výraz pro spojení mezi dvěma uzly. Nemusí jít jen o technické spojení, vazba může být nositelem celé řady atributů, podobně jako uzel (například platba jako vazba mezi uzly – účty, bude obsahovat částku, měnu, datum a další údaje).
  • Soused: Nejbližší uzel k danému uzlu.
  • List: Listy konkrétního uzlu jsou nejbližší uzly – sousedé, kteří už další vazbu nemají.
  • Popisek: Text doprovázející grafické zobrazení entity. Může obsahovat jeden nebo více atributů entity, statický text (pro všechny entity stejného typu), nebo kombinaci obojího.

Instalace

Požadavky

Vizualizační nástroj je určen pro prostředí Windows, od verze Windows 7 SP1. Pro plynulý a bezproblémový chod programu je třeba mít nainstalovánu JAVA 1.8 a minimálně 4GB RAM. Doporučená velikost monitoru je nejméně 19’’ a rozlišení 1200x1024. Pro větší objemy zpracovávaných dat je vhodné zvýšit množství paměti a rozlišení/velikost monitoru.

Instalace a první start

Aplikaci je možné dodat v režimu, kdy instalace v prostředí Windows nevyžaduje administrátorská práva. Stačí rozbalit dodaný aplikační balík do složky umístěné kdekoliv. ClueMaker pak nastartujete spuštěním cluemaker.exe, případně cluemaker64.exe pro 64 bitové procesory. Najdete je v adresáři ../cluemaker/bin.

Druhou možností je dodávka instalačního balíku, který se o vše potřebné postará sám. Vytvoří se ikona na ploše, i ve start menu.

Licence

ClueMaker využívá k ověření platnosti licence textový klíč, který je distribuován oprávněným uživatelům. Při prvním spuštění aplikace, nebo když licence vypršela, se automaticky otevře okno žádající dodání platné licence.

Podle způsobu, jakým jste licenci obdrželi, buď zkopírujete řetězec licenčního klíče do pole pro jeho vložení, nebo v dolní části obrazovky vložíte licenční soubor z libovolného úložiště na vašem počítači. Po vložení platného klíče se dole objeví datum konce platnosti. Stisknutím tlačítka Uložit licenci se okno uzavře a aplikace je připravena k použití. Pokud je licence platná, aplikace při příštím spuštění již vložení licence nevyžaduje.

Licencni okno
Licence ClueMaker – vložení licenčního souboru.

Pracovní prostředí

Pracovní prostředí obsahuje definici zdrojů dat a entit, které používáme pro analytickou práci. Na začátku relace ClueMakeru je proto musíme nastavit. Funkci pro volbu pracovního prostředí nalezneme v hlavním menu: Soubor > Pracovní prostředí > Otevři pracovní prostředí, kde pomocí standardní obrazovky najdeme a vybereme soubor s definicí pracovního prostředí. (Tyto soubory mají příponu .sws .)

Alternativní způsoby spuštění

Kromě nejběžnějšího způsobu spuštění aplikace – kliknutím na ikonu aplikace nebo jejího zástupce na ploše můžeme aplikaci nastartovat a zároveň otevřít pracovní prostředí nebo uložený projekt:

  • Přetažením (drag and drop) souboru pracovního prostředí (přípona .sws) nebo projektu (přípona .spr) na ikonu aplikace nebo zástupce aplikace.
  • Pomocí příkazové řádky v okně cmd.exe:
    • ./cluemaker64.exe –o [cesta_k_souboru]
    • ./cluemaker64.exe --open [cesta_k_souboru]
    • ./cluemaker64.exe [cesta_k_souboru]

Pracovní plocha

Po spuštění aplikace se zobrazí prázdná pracovní plocha, rozdělená do panelů s ovládacími prvky a plochou pro zobrazení grafu. Základní rozmístění je na následujícím obrázku.

Pracovni plocha
Práce s panely pracovní plochy

Velikost jednotlivých panelů je možné měnit potažením za jejich okraj. Další možnosti jsou oddokování a přemístění oken.

Oddokování okna

Funkce Oddokovat uvolní zvolené okno panelu od ostatních a umožní jeho nezávislé umístění na druhém monitoru. Opakem je funkce Dokovat okno, která je opět připojí k hlavní obrazovce ClueMakeru. Obě funkce naleznete v kontextovém menu po stisknutí pravého tlačítka myši na záložce zvoleného modulu.

Přemístění okna

Okno panelu lze přemístit přetažením za záložku do nové polohy v hlavním okně. Při pohybu se obdélníkem zobrazuje přibližná nová pozice. Pro začátek doporučujeme panely ponechat v základní pozici.

Import dat z Excelu

Funkce Import dat z Excelu usnadňuje práci s daty uloženými v excelovém souboru. Umožňuje jak využití uložených schémat, tak i ad-hoc tvorbu uzlů a vazeb a následný import do grafu.

Průvodce Importem

Průvodce importem najdeme v hlavním menu pod Soubor>Import Excelu. Provede nás pěti obrazovkami.

Výběr souboru

Vybereme soubor pro zpracování a stiskneme tlačítko Následující.

Výběr souboru
Import Excelu – výběr souboru

Výběr řádků

V okně se zobrazí vzorek souboru, jeho řádky můžeme posunovat. Obsahuje maximálně 2000 řádků.

  1. Pokud má soubor záhlaví, zaškrtneme „Načti záhlaví z řádku“ a počet řádků. Další možnosti jsou volitelné.
  2. Zaškrtnutím „Importovat max. n řádků“ a uvedením počtu můžeme omezit velikost importovaného souboru.
  3. Řádky můžeme označit kliknutím, Ctrl-klik nebo Shift-click pro více řádků najednou, a označené řádky pak z importu vypustit pomocí tlačítka Vynech řádky, nebo je opět zahrnout pomocí Zahrň řádky. Slouží především k úpravě záhlaví …
Vyber radku
Import Excelu – výběr řádků

Výběr schématu pro import

Umožňuje buď vybrat jedno z uložených schémat s definicí entit, nebo definovat nové mapování od začátku. Po volbě možnosti stiskneme „Následující“ .

Vyber schemat
Import Excelu – výběr schématu pro import

Mapování sloupců

Pokud jsme v předchozím kroku zvolili uložené schéma, v okně se zobrazí předdefinované entity a můžeme přejít k bodu d). V případě volby „Nové mapování“ je okno prázdné. Pak:

  1. Volbou +Přidej uzel a následným kliknutím do okna přidáme ikonu uzlu, opakujeme pro každý uzel který potřebujeme. Uzel pak zvolíme kliknutím a dodefinujeme:
  2. V poli Entita zvolíme jednu ze seznamu entitu, například „Phone“. V grafu se zobrazí příslušná ikona a vedle grafu předdefinovaný seznam atributů.
  3. Přidání vazby mezi uzly provedeme kliknutím na +Přidej vazbu a myší přetáhneme čáru z jednoho uzlu k druhému. Vpravo od grafu můžeme označit vazbu jako orientovanou.
  4. Pak nastavíme Id a Popisek (Label) uzlu. Lze to provést:
    • Kliknutím na sloupec, který hodláme použít a jeho přetažením na ikonu. V tomto případě nastavíme stejný atribut pro Id i Popisek.
    • Kliknutím na sloupec a jeho přetažením na položku Id nebo Popisek nebo napsáním jména sloupce v hranaté závorce do příslušného pole. Tato možnost umožňuje kombinovat v poli více atributů s neměnným textem. Například Id [Volající] – [Místo] .
  5. Pozor: Definice Id je důležitá: Všechny řádky (Entity) se stejným Id budou v grafu zobrazeny jako jeden objekt. Nevhodná kombinace Id a popisku může být v grafu zavádějící. Tři příklady uvádí tabulka :

    Příklad A Příklad B Příklad C
    Řádky v souboru Id Popisek uzlu Id Popisek uzlu Id Popisek uzlu
    Volajici Misto [Volajici] [Volajici]-[Misto] [Volajici]-[Misto] [Misto] [Misto] [Volajici]-[Misto]
    606707808 Praha 606707808 606707808-Praha 606707808-Praha Praha Praha 606707808-Praha
    606707808 Wien 606707808-Wien Wien Wien 606707808-Wien
    545000111 Berlin 545000111 545000111-Berlin 545000111-Berlin Berlin Berlin 545000111-Berlin
    545000111 Praha 545000111-Praha Praha
    545000111 Wien 545000111-Wien Wien

    Příklad A: Pro našich pět řádků se v grafu se objeví pouze dva uzly s popisky, obsahujícími Volajícího a Místo z prvého nalezeného záznamu. Může být zavádějící.

    Příklad B: V grafu se objeví všech pět uzlů, v jejich popisku bude pouze Místo. Věcně správné, ale stejný popisek se v grafu opakuje, nepoznáme z něj o jaké číslo jde.

    Příklad C: V grafu se objeví tři uzly pro Místa. Popisek je zavádějící, uvádí sice správný název místa, ale opět jen první nalezené číslo k danému místu, navíc na prvém místě.

  6. Další atributy, které chceme u uzlu vidět, nastavíme přetažením sloupce do příslušného předdefinovaného pole, nebo napsáním názvu sloupce v hranaté závorce do tohoto pole ( atributu). Tlačítka +Přidej a –Odstraň nad seznamem polí umožňují přidat entitě nová pole nebo pole odstranit.
  7. Můžeme dodefinovat vazbu – tyto informace jsou nepovinné. Zatržením pole Orientovaná vazba určujeme, že si vazba zachová směr. Zatržením pole Entita označíme vazbu jako entitu která obsahuje atributy. Pak je nutné doplnit minimálně ID této vazby-entity. Další atributy této vazby nastavíme stejně jako v bodu e). Nakonec stiskneme tlačítko Následující.
Mapovani
Import Excelu – mapování sloupců s definicí orientované vazby - entity

Import dat

Poslední obrazovka průvodce zobrazí počet importovaných uzlů a vazeb a nabídne uložení vytvořené šablony, tedy schématu s mapováním na sloupce excelu. Stisk tlačítka Dokončit je poslední krok po němž se entity zobrazí v grafu.

Import dat
Import Excelu – Import dat

Práce s daty z Excelu

Práce s grafem, který obsahuje výsledek importu z Excelu, se liší od práce s daty z připojené databáze pouze v tom, že neumožňuje dohledávání dat. Bezprostředně po importu obsahuje graf a tabulka dat veškerá data podle definice importu a pokud jsou pak při práci s grafem některé uzly nebo vazby odstraněny, lze je dostat zpátky jen návratem k předchozímu stavu – pomocí tlačítka Zpět v okně Grafu.

Automatický import

Aplikace umožňuje importovat data z připravené šablony automaticky. Syntaxe je následující: cluemaker64.exe -t/--template sablona.eitp -e/--excel data.xlsx Za přepínačem -t je uložená šablona a za přepínačem -e data, která splňují formát, který šablona očekává. ClueMaker nekontroluje formát dat a pokusí se je naimportovat. Tato funkce je vhodná pro integraci ClueMakeru s aplikacemi 3. stran.

Import dat z databáze

Import zahájíme volbou funkce Vyhledání entit v menu okna Graf:

Vyhledani entit
Ikona pro Vyhledávání entit

Zobrazí se okno Vyhledání entit.

Vyhledavani entit
Vyhledávání entit

Výběr entity: V horní části okna , po kliknutí na šipku vpravo, vybereme z dostupných entit tu, kterou budeme importovat. V závislosti na zvolené entitě se v následujícím řádku zobrazí datové zdroje, obsahující tuto entitu a pod nimi pak atributy této entity, které umožňují vyhledávání.

Volba datového zdroje: Výběr zdrojů můžeme pomocí zaškrtávacích okének upřesnit.

Výběr hodnot atributů: Pro každý atribut můžeme uvést jeden přesný výraz nebo masku, řetězec který se může vyskytnout kdekoliv v hledaného výrazu, nebo seznam hledaných jmen (přesných výrazů). Tyto možnosti se pro každý atribut nastavují po kliknutí na šipku na pravé straně políčka atributu. Defaultně je nastaveno ‘=’.

  • Přesný výraz napíšeme přímo do pole atributu za zobrazené ‘=’. Pro tvorbu masky slouží znak procento ‘%’, které nahrazuje libovolný počet znaků. Například zadaná maska ‘Profi%t’ nalezne nejenom ‘Profinit’ ale i ’Profi soft’, nebo ’Prof. JUDr. Karel Podešva, advokát’ a další. Některé datové zdroje použití masky neumožňují.
  • Hledaný řetězec zadáme po výběru možnosti ‘Obsahuje’ .
  • Seznam hledaných jmen zadáme po výběru možnosti ‘v’ která nám umožní zadat řadu hodnot.

V obou posledních případech nemá ’%‘ význam divoké karty. Při nastavení výběru pro více atributů platí logické AND – všechny podmínky musí být splněny. Zda bude hledání rozlišovat malá a velká písmena závisí na konkrétním datovém zdroji.

Vyhledavani priklad
Vyhledávání entit – příklad s daty

Výše uvedený příklad s výběrem podle dvou atributů by nalezl ty položky s výskytem řetězce Profinit ve jménu , které by v poli Adresa měly právě jen jméno jednoho z uvedených měst. Po nastavení parametrů stiskneme tlačítko Vyhledat. Po úspěšném výběru se zobrazí okno Výsledek hledání. Zde je možné kliknutím na záhlaví sloupce (jméno atributu) seznam sestupně nebo vzestupně setřídit.

Vyhledavani vysledek
Výsledek hledání entit s výběrem dvou řádků

Tlačítko Přidat … řádků ukazuje kolik řádků bude importováno. Defaultně je nastaven import všech nalezených záznamů. Pokud chceme importovat jen některé záznamy označíme je kliknutím na daný řádek. Pomocí Ctrl – klik můžeme označit více řádků, nebo Shift – klik vybere všechny řádky mezi dvěma námi označenými.

Tlačítkem Přidat … řádků pak provedeme import do grafu. Import můžeme opakovat s různými parametry a entitami a přidávat tak další data do našeho grafu. Po úspěšném importu se přidané položky zobrazí v grafu.

Práce s grafem

V této kapitole se budeme věnovat ovládání zobrazení, dohledávání dat pro zobrazené uzly a uložení výběru.

Ovládání zobrazení

Pro ovládání zobrazení grafu slouží funkce volané z menu v okně Graf, jejichž přehled ukazuje následující obrázek, zároveň využijeme funkce myši a panel Navigátor.

Funkce myši v grafu

Kolečko myši má funkci přiblížit nebo oddálit zobrazení.

Levým tlačítkem myši označujeme jednotlivé položky – vybíráme je pro další akci. Ctrl-klik slouží pro označení více jednotlivých položek a obdélník tažením myši označí množinu položek uvnitř.

Levým tlačítkem stisknutým nad vybranou entitou můžeme tuto entitu a s ní všechny označené entity přetáhnout do jiné pozice.

Pravým tlačítkem myši stisknutým kdekoliv v grafu můžeme celý graf přetáhnout do jiné pozice.

Prehled funkci
Přehled funkcí z menu Grafu

Přehled funkcí z menu Grafu

Zpět: vrací graf jeden krok zpět. Krokem zpět se aktivuje fukce Znovu. Pokud ovšem provedem nějakou změnu grafu, graf se dostává do aktuálního stavu a funkce Znovu je deaktivována.

Znovu: vrací stornovaný krok (kroky).

Přiblížit: zvětšení zobrazení (zoom in).

Oddálit: zmenšení zobrazení (zoom out).

Přiblížit vybranou oblast: po stisku tlačítka označíte myší oblast grafu – tato oblast bude přiblížena.

Zobrazit celý graf: umístí všechny entity na plochu grafu (v případě potřeby zmenší zobrazení).

Výběr algoritmu pro layout: Rozbalovací menu nabízí několik algoritmů. Vybraný algoritmus se spustí tlačítkem Provedení layoutu. Pro každou množinu dat se hodí jiný druh zobrazovacího algoritmu, vhodné je si je vyzkoušet.

Invertovat výběr: nevybrané (neoznačené) položky se stanou vybranými a naopak.

Odstranit vše: vyčistí graf. Pokud se tak stalo nedopatřením, lze použít zpět.

Odstranit vybrané elementy: odstraní pouze označené prvky.

Panel Navigátor je propojený s panelem Graf a usnadňuje orientaci v grafu tehdy, když pracujeme s velkým počtem položek, které je obtížné všechny přehledně zobrazit v okně grafu. V Navigátoru můžeme vidět celou plochu vytvořeného grafu a obdélník, který označuje oblast zobrazenou v okně Graf. Pohyb obdélníku v okně Navigátoru přetažením myší se promítá do oblasti zobrazené v okně Grafu. A naopak posun v okně grafu nebo přiblížení/vzdálení zobrazí Navigátor změnou polohy nebo velikosti obdélníku.

Navigátor a Graf
Navigátor a Graf

Dohledání dat

Typický způsob práce spočívá v tom, že k vybraným entitám – uzlům grafu chceme dohledat další vazby s uzly. Jeden krok hledání nachází k vybraným uzlům jen nejbližší uzly, sousedy. Pokud chceme pokračovat dál, provedeme další hledání k označeným uzlům.

V grafu označíme ty uzly, ke kterým chceme dohledat data. Nad jedním z nich stiskneme pravé tlačítko myši: a z krátkého menu zvolíme “Vyhledání propojených…“ , ke kterému se zobrazí následující možnosti: Nové hledání, Vyhledat vše a Aktivní vazby.

Nové hledání

Tato funkce nabízí možnost upřesnění hledaných vazeb a uzlů v okně, které nabídne všechny relevantní vazby pro vybrané uzly. Pokud okno necháme v defaultním stavu, provede se hledání všech vazeb – stejně jako při volbě Vyhledat vše.

V příkladu na následujícím obrázku je nastaveno hledání čtyř vazeb ze sedmi možných.

Hledání entit
Hledání entit

V případě potřeby můžeme hledání nastavit ještě přesněji. Kliknutím na šipku vpravo od názvu vazby se otevřou další detaily, zobrazené v dalším obrázku.

Hledání entit s parametry
Hledání entit s parametry

Na obrázku jde o vazbu právnické osoby na fyzické osoby. Hledaná informace má v tomto případě dvě složky:

  • Vztah PO-FO, označený symbolem vazby Vazba , obsahuje atributy vazby.
  • Osoba, označená symbolem osoby Osoba , představuje hledaný uzel a obsahuje jeho atributy určené k vyhledávání.

V obou případech je pod názvem a symbolem entity i datový zdroj nebo zdroje, které mohou být prohledávány. V tomto oknu můžeme tedy upřesnit, o jaké informace máme v hledání zájem, například jen konkrétní funkci a příjmení nebo adresu osob. Tlačítko Vyhledat pak spustí hledání.

Vyhledat vše: Tato funkce použije při hledání všechny dostupné vazby.

Aktivní vazby: Stejné, jako Vyhledat vše, ale hledá pouze vazby označené jako aktivní.

Výběr sousedů a vazeb v grafu

Podobně, jako při dohledání dat, označíme v grafu uzel nebo uzly, ke kterým chceme vybrat sousedy. Nad vybraným uzlem stiskneme pravé tlačítko myši a z menu zvolíme “Vybrat” s nabídkou Sousední uzly, Sousední uzly listů a Vazby. V případě uzlů se pak zobrazí možnost “Všechny sousední uzly” a dále nabídka těch entit, které se k vybranému uzlu nebo uzlům mohou vázat.

Rozdíl mezi výběrem sousedních uzlů a sousedních uzlů listů spočívá v tom, že v druhém případě se označí jen koncoví sousedé, ti kteří nemají žádnou další vazbu. Pokud chceme označit také původně označené uzly, podržíme klávesu Shift.

Volba vazeb nabídne možnosti: Všechny vazby, Vstupní vazby, Výstupní vazby a pak i názvy vazeb, které se vybraného uzlu nebo uzlů týkají.

Zvýraznění a odstranění uzlů

Zvýraznění a odstranění uzlů jsou další funkce spouštěné pravým tlačítkem myši nad vybraným uzlem. Funkce Zvýraznit potlačí vzhled všech neoznačených uzlů. Po kliknutí na libovolnou část grafu zvýraznění zmizí.

Funkce Odstranit odstraní všechny označené uzly z projektu, pracuje stejně jako funkce Odstranit vybrané elementy spouštěná z menu okna Graf.

Textové vyhledávání v grafu

Po stisknutí kombinace Ctrl-f se ve spodní části okna Graf objeví pole, označené symbolem lupy, pro textové vyhledávání. Po zadání textového řetězce ho program okamžitě hledá v grafu a nalezené entity zvýrazní, respektive potlačí ostatní entity. Funkce tlačítek jsou následující:

  • Předchozí a Následující: zvětší část grafu s nalezenou entitou, kterou umístí doprostřed okna. Pomocí tlačítek je tak možné postupně zobrazovat všechny nalezené entity.
  • Aa: Umožňuje vypnout/zapnout rozlišování velkých a malých písmen
  • Výběr: Nalezené položky jsou označeny jako vybrané, umožňují tak využití dalších funkcí. Následující obrázek ukazuje část grafu s nalezenými položkami před a po stisknutí tlačítka Výběr.
Textové vyhledávání
Textové vyhledávání
Textové vyhledávání s volbou výběru
Textové vyhledávání s volbou výběru

Výběr prvků grafu

Jak je zřejmé z předchozích kapitol, výběr prvků grafu jejich označením, má význam pro řadu operací. Vybrané prvky můžeme najednou odstranit, dohledat k nim další uzly, přemístit atd. Často je proto výhodné si výběr uložit pro další použití. K tomu, a také k zobrazení detailních informací o vybraných prvcích grafu slouží panel Výběr.

Výběr – vybrané uzly
Výběr – vybrané uzly

V horní části panelu Výběr se zobrazují prvky grafu, které jsou aktuálně vybrané. Pokud je vybrán jen jeden prvek, zobrazí se i s detaily – s atributy. Pokud vybereme najednou více prvků, v okně se objeví jejich seznam a pro detail prvku je potřeba kliknout na + jak ukazuje příklad na obrázku.

Stisknutím tlačítka Ulož výběr se aktuální výběr uloží a zobrazí ve spodní části panelu.

Uložený výběr
Uložený výběr

Uložený výběr znovu aktivujeme v grafu kliknutím na jeho název v seznamu a tlačítkem Vybrat. Výběrů můžeme uložit až 255, pro lepší orientaci je vhodné je přejmenovat. Do uloženého výběru je možné přidávat nebo odstraňovat označené prvky, sloučit dva výběry, nebo ze dvou vyběrů vybrat pouze shodné prvky:

Přejmenování výběru: dvojklik na uložený výběr otevře pole, kde je možné změnit název.

Přidat vybrané prvky do výběru: klik na šipku u tlačítka Ulož výběr otevře menu. Volba Přidej do nabídne seznam uložených výběrů, kliknutím na název výběru se provede přidání položek.

Odstranit vybrané prvky z výběru: Podobně jako přidání položek: Zvolit Odstraň z a kliknout na název výběru.

Průnik vybraných prvků: Funkce Průnik defakto porovná prvky zvoleného uloženého výběru s aktuálními vybranými prvky (zobrazenými v horní části panelu Výběr) a v uloženém výběru ponechá jen ty, které se shodují.

Přidej vybrané uzly
Přidej vybrané uzly

Podobně funguje i menu pod uloženými výběry, ale s tím rozdílem, že místo prvků v horní části panelu pracujeme, tedy přidáváme, odstraňujeme, nebo provádíme průnik mezi zvoleným uloženým výběrem a cílovým uloženým výběrem, jak ukazuje následující obrázek.

Přidej uložený výběr
Přidej uložený výběr

Hledání cesty

Tato funkce slouží k nalezeni cest mezi dvěma uzly. Tlačítko Najdi cestu je aktivováno vždy, když jsou v grafu vybrány právě dva uzly. Po kliknutí na ně se otevře panel Hledání cesty.

Find Paths 1
Tlačítko "Najdi cestu"

Panel Hledání cesty nabízí možnost nastavení parametrů a dvě možnosti spuštění hledání, jak ukazuje následující obrázek.

Find Paths 2
Možnosti hledání cest

V horní části panelu je uveden počáteční a koncový uzel hledané cesty. Pokud je chceme prohodit, použijeme tlačítko Prohodit.

V sekci Zahrnout uzly máme možnost zvolit buď všechny typy entit, nebo vyběr cest omezit jen na některé entity.

Sekce Zahrnout vazby umožńuje omezit výběr cest na určitý typ vazeb.

Při volbě Ignorovat orientaci vazeb nebude přihlíženo na směrovou orientaci.

Možnost Zohlednit váhu vazby v délce znamená, že pokud jsou v grafu vazby s různými vahami, výpočet délky cesty je využije. (Běžně má jedna vazba délku jedna, při použití vah to bude její váha.)

Volba Zahrnout jen uzly způsobí, že označený výběr nebude zahrnovat vazby ale pouze uzly.

Minimální délka cesty a Maximální délka cesty se vyplní, pokud chceme hledat jen cesty o délce v těchto mezích.

Tlačítko Najít nejkratší cestu spustí hledání nejkratší cesty od počátečního uzlu ke koncovému.

Tlačítko Najít všechny cesty spustí hledání všech cest mezi dvěma zadanými uzly. V tomto případě musíme vyplnit hodnotu Maximální délka cesty.

Seznam nalezených cest se zobrazí ve výsledkové tabulce, kde můžeme kliknutím označit jeden nebo více řádků (pomocí Ctrl nebo Shift - clik). Tyto cesty budou pak zvýrazněny v grafu, jejich uzly, a pokud jsme nezaškrtli možnost "Zahrnout jen uzly", tak i vazby budou zobrazeny v panelu Výběr.

Find Paths 3
Výsledek hledání cest

Časová osa

V menu zvolte Nástroje - Časová osa. V okně graf se objeví časová osa, přičemž počáteční a koncový bod intervalu posunujte jednoduše myší. Entity, které splňují platnost vyznačenou časovou osou, budou zvýrazněny.

Timeline 1
Časová osa

Tabulka dat

Příkaz pro otevření panelu tabulky dat najdeme v hlavním menu pod Okno. Tabulka dat obsahuje všechny uzly a vazby, které se v aktuálním okamžiku nacházejí v grafu – v každém okamžiku je s grafem synchronizovaná. Platí to i pro výběr entit: ty označené jako vybrané v grafu jsou označeny i v tabulce. A naopak, pokud v tabulce dat entity kliknutím označíme, nebo naopak odznačíme, promítne se to do grafu.

Graf a tabulka dat
Graf a tabulka dat

Tlačítka Uzly,Vazby a Vybrané entity otevírají příslušný seznam popsaný dále. Tlačítko Sloupce umožňuje přidat nebo odebrat sloupce zobrazené v seznamu uzlů nebo vazeb.

Tabulka uzlů a vazeb

Panel s uzly nebo vazbami zobrazí seznam položek s jejich hlavními atributy. Setřídění seznamu provedeme kliknutím na záhlaví sloupce podle kterého chceme třídit, další kliknutí pak změní smysl třídění. Pro rozšíření seznamu o další sloupce použijeme tlačítko Sloupce, podrobnosti obsahuje následující sekce.

Výběr zobrazených sloupců

Nejprve zvolíme tabulku uzlů nebo vazeb. Po kliknutí na tlačítko Sloupce se zobrazí okno umožňující přidání nebo odebrání zobrazovaných sloupců pro zvolený seznam.

Výběr sloupců pro uzly
Výběr sloupců pro uzly
Výběr sloupců pro vazby
Výběr sloupců pro vazby

Atributy jsou rozděleny do tří skupin:

  • Klíčové údaje: obsahují základní identifikátory nebo pozici položky.
  • Vypočtené sloupce:. U uzlů jsou to počty vazeb a počty propojených uzlů, včetně možnosti počítat zvlášť vstupní a výstupní vazby. U vazeb se uvádí celkový počet vazeb zdrojového a cílového uzlu dané vazby.
  • Atributy entity: tyto atributy se budou lišit od entity k entitě.

Graf často obsahuje více entit, tedy typů uzlů s různými atributy. Když některé z nich vybereme pro zobrazení, v tabulce se objeví všechny vybrané sloupce, ale data budou vyplněna jen v řádcích těch entit, ke kterým daný atribut patří.

Vybrané entity

Opět nejprve zvolíme tabulku uzlů nebo vazeb. Pokud ve zvolené tabulce existují nějaké vybrané entity, bude tlačítko Vybrané entity aktivované a po jeho stisknutí se otevře okno se seznamem pouze těch entit, které jsou označeny jako vybrané. Tlačítkem Zobraz vše můžeme ukončit zobrazení jen vybraných entit.

Vybrané entity - vazby
Vybrané entity - vazby

Filtry

Filtry umožňují v grafu nalézt uzly nebo vazby podle různých kriterií, která mohou být kombinována. Vyfiltrované uzly mohou být vybrány (označeny) pro další akci, případně zobrazeny v grafu, přičemž ostatní uzly budou skryty. Filtrování je okamžité, protože pracuje jen s naimportovanými daty grafu. Filtry samotné také neodstraňují žádné uzly, mohou je pouze skrýt.

Pro práci s filtry slouží dva panely popsané v následujících sekcích.

Panel Filtry

Panel slouží k přidávání a uspořádání filtrů. Každé kliknutím na + Přidej filtr přidá zatím blíže nedefinovaný filtr, který následně vytvoříme v editoru. Práce s editorem filtrů je popsána v následující sekci. Pokud chceme současně použít několik filtrů, můžeme je aplikovat s podmínkou NEBO (OR) nebo podmínkou A(AND). V panelu tyto vzájemné podmínky ovládáme následovně:

Pro NEBO (OR) stačí ponechat filtry tak jak jsou seřazeny po přidání. Následující obrázek uvádí příklad, kdy v grafu budou vybrány všechny entity typu Firma a zároveň i entity typu Osoba s uvedenými příjemními.

Filtry ve vztahu NEBO (logické OR)
Filtry ve vztahu NEBO (logické OR)

Pro podmínku A (AND) je potřeba filtry spojené touto podmínkou přeskupit přetažením myší, jak ukazuje následující obrázek. Pod filtr Entity Firma jsme přidali filtr Počet vstupů propojený s firmou vazbou A (AND).. V grafu budou vybrány entity Osoba s uvedenými příjemními a Entity Firma, které zároveň splňují podmínku počtu vstupů (vazeb).

Filtry ve vztahu A (logické AND)
Filtry ve vztahu A (logické AND)

V okně Filtry kliknutím na symboly vlevo od názvu filtru ovládáme jeho vypnutí/zapnutí nebo odstranění. Tlačítko Vybrat provede v grafu výběr uzlů podle nastavených filtrů. Tlačítko Skrýt pak skryje všechny uzly (včetně jejich vazeb), které nevyhovují podmínkám filtrů.

Panel Editor filtrů

Do editoru filtrů přejdeme po kliknutí na filtr, který chceme editovat , v panelu Filtry. Editor Filtrů nabízí následující typy filtrů.

Filtr entit

Filtr entit, stejně jako další typy filtrů, nabízí záložky Formulář a Histogram. Formulář slouží pro přímý zápis požadované hodnoty nebo hodnot a je vhodný tam, kde je seznam hodnot dlouhý. Ukážeme si to v další sekci.

Pro filtr entit můžeme použít Histogram, který zobrazí všechny typy entit, které v grafu existují. Entitu vyberete kliknutím na její název. Zaškrtnutím Vybrat vše provedeme výběr všech položek seznamu. Výběr můžeme zrušit kliknutím na vybranou položku.

Práci s dlouhými seznamy nám usnadní setřídění pomocí tlačítka Třídit podle: Hodnoty nebo Pořadí výskytu. Nové kliknutí na Hodnoty nebo Pořadí obrátí setřídění od vzestupného k sestupnému a naopak.

Obrázek ukazuje příklad filtru s vybranými dvěma entitami.

Filtr entit
Filtr entit

Filtr položek

V případě filtru položek musíme kromě entity vybrat z dalšího rozbalovacího seznamu i položku, kterou chceme filtrovat. Použijme tentokrát Formulář, který nabízí tři možnosti zápisu hodnot: [=] pro zápis přesné hodnoty, [Obsahuje] pro zápis řetězce, obsaženého kdekoliv v hledaném poli, a [v] pro záznam více přesných hodnot. Poslední možnost je na obrázku:

Filtr položek
Filtr položek

Filtr počtu sousedů

V případě filtru počtu sousedů nabízí přepínací tlačítko možnosti:

  • Počítej vazby: pro každý uzel v grafu spočítá vazby. Mezi dvěma uzly může být více vazeb, proto se jejich počet může lišit od počtu sousedů
  • Počítej sousedy: pro každý uzel v grafu spočítá sousedy.

Záložka Histogram zobrazí nalezené hodnoty. Udaná hodnota, například ‘Počet 17‘ znamená, že v grafu existuje alespoň jeden uzel, který má 17 sousedů. Výběr hodnot pro filtr provedeme stejným způsobem, jako u předchozích filtrů.

Filtr počtu sousedů
Filtr počtu sousedů

Filtr vazeb

Filtr vazeb využívá popisky vazeb. I zde můžeme využít jak Formulář, tak i Histogram. Obrázek ukazuje druhý případ.

Filtr vazeb
Filtr vazeb

Časová osa

Časová osa je speciální podtyp filtrů. Pro správnou funkčnost je třeba mít nadefinované atributy start a end date. Je možné definovat krok, po kterém se bude kraj intervalu pohybovat. Časová osa uzly nemaže, jen využívá zvýrazňování.

Tvorba vlastních uzlů a vazeb

Aplikace nabízí možnost doplnit na plochu grafu vlastní uzly a vazby. Na prázdné ploše tak můžete vytvořit svůj vlastní graf, nebo doplnit nové prvky do grafu vytvořeného importem dat.

Tvorba uzlů

Pro tvorbu uzlů slouží panel Paleta a jeho sekce Vytvoř uzly, kde jsou zobrazeny ikony s názvem typu uzlu. Uzel přidáme do grafu přetažením zvolené ikony, nebo kliknutím na vybranou ikonu a novým kliknutím v ploše grafu.

Popisek uzlů v grafu můžeme změnit po dvojkliku na text.

Sekce Vytvoř vazby panelu Paleta nabízí výběr několika typů vazeb. Obecné vazby jsou buď orientované nabo neorientované. Vazby-entity zpravidla obsahují další položky, vztahující se k danému typu vazby. Nabídka vazeb-entit závisí na zvoleném pracovním prostředí (telefonát, transakce ...)

Pro přidání vazby do grafu, klikněte na zvolený typ vazby a pak tažením myši spojte v grafu uzly. Popisek vazby je možné editovat stejným způsobem, jako u uzlu.

Vlastní uzly a vazby
Příklad grafu s vlastními uzly a vazbami

Reporty

Pro data uložená v databázích umožňuje ClueMaker spouštění uložených reportů, které poskytnou formátovaný výstup v podobě tabulky nebo grafu.

Rozlišujeme dva druhy reportů: Entitní reporty jsou spojeny s konkréním typem entity, který se vyskytuje v aktuálním grafu. Obecné reporty naopak nemají žádnou vazbu na data v grafu.

Entitní reporty

Volbu Reporty najdeme po kliknutí na pravé tlačítko myši nad jedním z vybraných uzlů grafu. Tato volba je aktivována pouze tehdy, když graf obsahuje typ entity s kterou je některý entitní report svázán.

Volba Reporty pak zobrazí dostupné entitní reporty. Po provedení výběru se report spustí a výsledek se zobrazí na samostatném panelu nesoucím jméno reportu.

Report
Příklad reportu

Stisknuté tlačítko Aktualizovat pro výběr znamená, že report se bude aktualizovat po každé změně vybraných uzlů entit, na které je navázán. Tlačítko Export do HTML umožňuje uložit vytvořený report jako soubor formátu HTML.

Obecné reporty

Obecné reporty se spouští z hlavního menu Nástroje > Spuštění reportu. Otevře se okno s nabídkou všech obecných reportů.

V závislosti na definici reportu může zvolený report vyžadovat zadání jednoho nebo více parametrů. Po provedení je výstup prezentován stejným způsobem jako u entitního reportu.

Práce s GIS a mapou

Mapová část aplikace ClueMaker se skládá ze 2 součástí, z hlavní mapové obrazovky a z panelu vrstev.

GIS nástroje
Panel nástrojů okna GIS

Obrazovka s mapou obsahuje kromě mapy i lištu s nástroji, odkud je možné spustit:

  • dialog konfigurace,
  • export právě zobrazené části mapy do formátu PNG,
  • lištu měření vzdálenosti,
  • import entit podle lokality z datového zdroje do grafu nebo z grafu do mapy,
  • kreslení útvarů.
Graf na mapě
Příklad obrazovky s grafem na mapě

Panel vrstev se nachází v pravé straně obrazovky a obsahuje zaškrtávací políčka vrstev, které určují, zda se daná vrstva zobrazí na mapě.

Uzly a hrany

Rovnako ako v grafe, aj na mape sa zobrazujú uzly a grafy. Uzly se umístní buď na místo, které mají namapované v atributech, nebo když jej nemají definované, tak na náhodné místo poblíž polohy, která se dá upravit v konfiguraci.

Existují zde 2 módy zobrazení grafu na mapě:

  • zjednodušený mód, ve kterém se uzly zobrazují jen ako tečky a pokud mají uzly mezi sebou vícero hran, zobrazí se jako jedna,
  • plný mód, kde se zobrazí všechny hrany a uzly mají svoje ikony ako v grafu.
Plný mód
Plný mód zobrazení
Zjednodušený mód
Zjednodušený mód zobrazení

Rozmístnění uzlů i aktuální zobrazená oblast mapy se ukládají s projektem.

Vkládání uzlů z grafu

Uzly lze vkládat z grafu pomocí volby z kontextového menu, které lze vyvolat pravým tlačítkem myši a lze buď přidat označené uzly, nebo všechny uzly, které mají geografickou lokalitu.

Import podle lokality

Entity lze podle lokality importovat buď z grafu do mapy, nebo z datového zdroje do grafu. Tyto akce je možné vyvolat buď z lišty nástrojů v horní části obrazovky, nebo z kontextového menu nakreslených útvarů nebo zvýrazněné vzdáleností od uzlu.

Import z grafu
Dialog importu z grafu

Při importu vyvolaném z lišty nástrojů je potřebné zadat souřadnice a vzdálenost, pomocí které se sestrojí kružnice se středem v zadaných souřadnicích a importují se ty uzly, které leží uvnitř vytvořené kružnice.

Import z datového zdroje
Dialog importu z datového zdroje

Při vyvolání importu z kontextového menu nakresleného útvaru nebo zvýrazněné vzdálenosti od uzlu budou importovány entity, které se nacházejí uvnitř daného útvaru (nebo zvýrazněné vzdálenosti). V případě, že byl import vyvolán z lomené čáry, užívatel bude ještě dotázán o doplnění vzdálenosti od lomené čáry, ze které se má importovat.

Kreslení útvarů na mapu

Na mapu lze kreslit různé útvary, např. kruh, elipsu nebo lomenou čáru. Kreslení se spouští tlačítkem na liště nástrojů v horní části obrazovky. Kreslený útvar je možné vybrat pomocí rozbalovacího seznamu vedle tlačítka kreslení. Pro dokončení kreslení je potřebné ho ukončit opětovným kliknmutím na tlačítko kreslení. Útvar je možné smazat z mapy příslušnou volbou z kontextového menu. Nakreslené útvary v rámci projektu nelze uložit.

Konfigurace

Konfigurace GIS se spouští z lišty nástrojů nahoře. V této konfiguraci lze nastavit např. barvy uzlů, hran a jejich popisků. Dají se zde také měnit barvy kreslených útvarů i lomené čáry měření vzdálenosti. Dále se zde nastavuje výška pohledu, po překročení které se mění mód zobrazení z plného na zjednodušený. Nachází se zde i nastavení sloužící ke správě zdrojů map a mapových vrstev.

Správa zdrojů map

V této sekci konfigurace se nachází karty jednotlivých serverů - zdrojů mapových vrstev. Na těchto kartách se nachází zaškrtávací políčka pro všechny mapové vrstvy, které daný server poskytuje. Vrstvy se zaškrtnutým políčkem budou dostupné na panelu vrstev, odkud je bude možné vybrat a zobrazit na mapě.

Nastavení vrstev a serverů
Dialog přídání nového serveru

Samotné servery je možné přidat tlačítkem "Přidat server", které vyvolá dialog pro zadání URL přislušného serveru. Vo její vyplnění a potvrzení dialogu se v případě, že byla zadána URL, na které je spuštěn server, který je podporován (WMS), vytvoří nová karta s vrstvami daného serveru. Přidané servery lze zmazat pomocí tlačitka "Odebrat server", čím se odstraní server, na kterého kartě se nacházíme. Touto akcí se odstraní i všechny vrstvy poskytované dotčeným serverem.

Přidané servery i výběr vrstev na panel se ukládají spolu s projektem.

Layout událostí

Při označení jednoho nebo více uzlů a po kliknutí pravým tlačítkem myši a zvolení možnosti "Zobrazit události" je možné vizualizovat interakce v čase mezi zvolenými uzly. Takovéto zobrazení je vhodné např. při zkoumání pohybu peněz mezi účty nebo při sledování posloupnosti hovorů mezi telefonními čísly. Nad tímto layoutem lze také vyvolat časovou osu, která zvýrazní uzly platné ve vybraném časovém období.
Layout událostí
Layout událostí

Výběr entit pro události

Na začátku se otevře průvodce, ve kterém lze vybrat entity, které v našem projektu reprezentují nějaký typ události, který chceme sledovat.
Výběr entit
Výběr entit

Konfigurace

Layout je konfigurovatelný, lze nastavovat způsob vykreslení - pravidelné, nebo poměrně k časovým odstupům mezi událostmi. Také je možné vybrat jen události platné v daný datumový rozsah.

Ukládání projektu

Uložení projektu

Příkaz pro uložení projektu nalezneme v hlavním menu pod Soubor > Uložit projekt, případně Soubor > Projekt > Uložit projekt jako. Tím se otevře standardní okno pro ukládání souborů, kde zvolíme úložiště, projektu dáme název a uložíme jako typ ClueMaker project. Uložené projekty mají příponu spr.

Projekt můžeme kdykoliv uložit také stisknutím Ctrl-S.

Otevření projektu

Funkci otevření uloženého projektu najdeme v hlavním menu pod Soubor > Projekt > Otevři project, nebo stisknutím Ctrl-O. Pokud graf/tabulka dat obsahuje nějaká data, zobrazí se dotaz na uložení těchto dat.

Po otevření projektu zobrazí ClueMaker data , graf nebo tabulku, ve stavu, jako při uložení projektu. Pokud chcete pracovat i se zdrojovou databází, například dohledávat další vazby a uzly, musíte mít otevřený také příslušný pracovní prostor.